Derby
  1. Derby
  2. DERBY-3295

DataSourceTest.testConnectionErrorEvent() failed with AssertionFailedError

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
      ibm16, svn # 605788
    • Bug behavior facts:
      Regression Test Failure

      Description

      Running suites.All with ibm16 on 12/19 I saw the following failure:

      There was 1 failure:
      1) testConnectionErrorEvent(org.apache.derbyTesting.functionTests.tests.jdbc4.DataSourceTest)junit.framework.AssertionFailedError
      at org.apache.derbyTesting.functionTests.tests.jdbc4.DataSourceTest.testConnectionErrorEvent(DataSourceTest.java:208)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:45)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:96)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)

      The line in DataSourceTest that threw the assertion failure was line 208:

      //Now try to use various apis on the JDBC Connection object created
      //before shutdown and they all should generate connection error event.
      ...
      assertTrue(aes12.didConnectionErrorEventHappen());

        Activity

        Gavin made changes -
        Workflow jira [ 12419759 ] Default workflow, editable Closed status [ 12797333 ]
        Myrna van Lunteren made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]
        Myrna van Lunteren added a comment -

        Looks like we've not seen this again. If it happens again, this issue can be reopened.

        Dag H. Wanvik made changes -
        Component/s Test [ 11413 ]
        Dag H. Wanvik made changes -
        Component/s Regression Test Failure [ 12310664 ]
        Dag H. Wanvik made changes -
        Derby Categories [Regression Test Failure]
        Kathey Marsden added a comment -

        Mamta, is this still a problem? I see just the one instance of the failure in December 2007.

        Mamta A. Satoor made changes -
        Fix Version/s 10.4.0.0 [ 12312540 ]
        Mamta A. Satoor added a comment -

        Removing the fix in version for now

        Dyre Tjeldvoll added a comment -

        This issue is targeted for 10.4, but has not been updated in 2008. Should the fix-version be changed/removed?

        Mamta A. Satoor made changes -
        Field Original Value New Value
        Assignee Mamta A. Satoor [ mamtas ]
        Mamta A. Satoor added a comment -

        Army, I will take a look at this once I am back from holidays

        A B created issue -

          People

          • Assignee:
            Mamta A. Satoor
            Reporter:
            A B
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development