Derby
  1. Derby
  2. DERBY-3284

AssertionFailedError in testStalePlansOnLargeTable(org.apache.derbyTesting.functionTests.tests.lang.StalePlansTest)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 10.4.1.3
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
      OS: Solaris Nevada snv_27a X86 64 bits - SunOS 5.11 snv_27
      JVM: Sun Microsystems Inc. 1.6.0-b105
    • Bug behavior facts:
      Regression Test Failure

      Description

      See http://dbtg.thresher.com/derby/test/trunk16/jvmAll/testing/testlog/JDK16Jvm1.6SunOS-5.11_i86pc-i386/604668-org.apache.derbyTesting.functionTests.suites.All_diff.txt

      There was 1 failure:
      1) testStalePlansOnLargeTable(org.apache.derbyTesting.functionTests.tests.lang.StalePlansTest)junit.framework.AssertionFailedError
      at org.apache.derbyTesting.functionTests.tests.lang.StalePlansTest.testStalePlansOnLargeTable(StalePlansTest.java:264)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:96)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)

        Issue Links

          Activity

          Rick Hillegas added a comment -

          Saw this on a private distribution (10.6.2.3 svn 1557765) on JVM Oracle Enterprise Linux ia32_jdk6.

          Kathey Marsden added a comment -

          This is a duplicate of DERBY-2949

          Knut Anders Hatlen added a comment -

          For the record, this is the assert that fails:

          // Expect this to use table scan, as the above update has basically
          // made all the rows in the table be equal to "1", thus using the index
          // does not help if all the rows are going to qualify.
          assertTrue(SQLUtilities.
          getRuntimeStatisticsParser(stmt).usedTableScan());


            People

            • Assignee:
              Unassigned
              Reporter:
              Ole Solberg
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development