Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-3104

Outdated build information in http://db.apache.org/derby/manuals/dita.html

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Web Site
    • Labels:
      None

      Description

      The DITA Source page of the Derby web site (http://db.apache.org/derby/manuals/dita.html) states that Apache Ant Version 1.6.2 and JDK 1.4.2 are required to build the documentation.

      In fact, I have found out (mostly by accident) that it is possible to build the documentation using Apache Ant Version 1.6.5 and either JDK 1.5 or JDK 6. For me this works on either Solaris or Windows XP.

      I don't know if the behavior has actually changed (i.e. someone modified the toolkit to work with later Ants and JDKs) or if the page was first written when Ant 1.6.2 and JDK 1.4.2 were current.

      It would be a good idea to change this page to reflect the current situation, if someone else can confirm that later software versions work.

      I have not tried Ant 1.7.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                chaase3 Camilla Haase
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: