Derby
  1. Derby
  2. DERBY-3070

Developer's Guide upgrade topic "Soft upgrade limitations" needs updating for 10.3

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.3.1.4, 10.4.2.0, 10.5.1.1
    • Fix Version/s: 10.6.1.0
    • Component/s: Documentation
    • Labels:
      None

      Description

      The "Soft upgrade limitations" topic in the Developer's Guide (http://db.apache.org/derby/docs/dev/devguide/tdevupgradesoft.html) does not seem to have been updated for 10.3. Would it be possible for someone to provide lists of the following, so I can make the edits:

      Version 10.3 features that can't be used in a database upgraded from 10.0 (are these the same as the 10.2 features listed?)

      Version 10.3 features that can't be used in a database upgraded from 10.1 ((are these the same as the 10.2 features listed?)

      Version 10.3 features that can't be used in a database upgraded from 10.2 (collation, apparently; any others?)

      It would be good to know if the territory attribute needs to be added to one of these lists (see DERBY-2185).

      1. tdevupgradesoft.html
        5 kB
        Kim Haase
      2. DERBY-3070.diff
        2 kB
        Kim Haase

        Activity

        Kim Haase added a comment -

        Closing, since fix appeared in Latest Alpha Manuals a while ago.

        Kim Haase added a comment -

        Committed patch DERBY-3070.diff to documentation trunk at revision 765690.

        Kim Haase added a comment -

        Thank you, Rick. I'll go ahead and commit this, knowing it won't make 10.5 (no need to respin the docs for this). In fact, I think I'll downgrade it to Minor.

        Rick Hillegas added a comment -

        Thanks, Kim. Looks good. +1.

        Kim Haase added a comment -

        Attaching DERBY-3070.diff and tdevupgradesoft.html, which make the topic on soft upgrade general rather than applying it to specific releases.

        M src/devguide/tdevupgradesoft.dita

        Kim Haase added a comment -

        The information in the soft upgrade topic (http://db.apache.org/derby/docs/dev/devguide/tdevupgradesoft.html) is way out of date now. Updating it for each release is impractical, and no user has complained about it.

        It would make more sense to remove release-specific information from the topic and to say in general terms which kinds of new features can be used with soft upgrade and which kinds can't. Specifically, features that "affect database structure" can't be used with soft upgrade.

        I thought the release notes contained more specific information, but they don't seem to. Users will have to figure out which features can be used with soft upgrade and which can't. Since that is the situation currently for all releases after 10.2, this doesn't cause a significant regression.

        I'll post a patch soon unless someone has a better proposal.


          People

          • Assignee:
            Kim Haase
            Reporter:
            Kim Haase
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development