Derby
  1. Derby
  2. DERBY-2589

'Exception while trying to insert row number: XXXXX' in store/OnlineCompressTest.java

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 10.3.1.4
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
      OS: Microsoft(R) Windows(R) Server 2003, - 5.2.3790 Service Pack 1 - WindowsNT 2 5
      JVM: Sun Microsystems Inc. 1.6.0-b105
    • Bug behavior facts:
      Regression Test Failure

      Description

      Seen in http://dbtg.thresher.com/derby/test/Daily/jvm1.6/testing/testlog/w2003/531991-storeall_diff.txt

      <method>
      store/OnlineCompressTest.java
      </method>

      <signature>
      82 del
      < Executing test: no delete case complete.
      83 del
      < Executing test: delete all rows case succeeded.
      84 del
      < Executing test: end simple deleteAllRows,104000 row test.
      85 del
      < Ending test: test6
      85 add
      > Exception while trying to insert row number: 27144
      > ERROR XSLA1: Log Record has been sent to the stream, but it cannot be applied to the store (Object null). This may cause recovery problems also.
      > ERROR XSLAA: The store has been marked for shutdown by an earlier exception.
      > ERROR XSDG3: Meta-data for Container org.apache.derby.impl.store.raw.data.RAFContainer4@1afb0c7 could not be accessed
      > ERROR XJ001: Java exception: ': java.io.EOFException'.
      > java.sql.SQLException: Log Record has been sent to the stream, but it cannot be applied to the store (Object null). This may cause recovery problems also.
      > Caused by: java.sql.SQLException: Log Record has been sent to the stream, but it cannot be applied to the store (Object null). This may cause recovery problems also.
      > ... 7 more
      </signature>

        Issue Links

          Activity

          Mike Matrigali added a comment -

          any chance you can post a link or a zip of the results of this test. The exception included is likely not the actual cause of the bug. That exception usually comes after the actual thing that caused the database to shutdown. On a serious server shutting down error we basically disable the log so that no other write operations will happen and thus any attempts get the errror that is included above. hopefully derby.log has the error that preceded this one.

          Ole Solberg added a comment -

          I have added a zip of the storeall results as
          http://dbtg.thresher.com/derby/test/debug/531991_storeall.zip

          Rick Hillegas added a comment -

          For the record, I do not see this error in the regression test runs for the 10.3 branch.

          Kathey Marsden added a comment -

          Unchecking Regession checkbox as this is not a confirmed product regression

          Knut Anders Hatlen added a comment -

          I think this is the same issue as DERBY-3347. Marking it as resolved.


            People

            • Assignee:
              Unassigned
              Reporter:
              Ole Solberg
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development