Derby
  1. Derby
  2. DERBY-165

Droppping columns with ALTER TABLE errors out

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: SQL
    • Labels:
      None
    • Environment:
      Linux

      Description

      When I try to drop columns using ALTER TABLE command I get the following error, irrespective of me using "column" keyword in addition to the drop keyword.

      ---------------------ERROR REPORT------------------------------------------
      ij> alter table test_linux drop column dept;
      ERROR 42X01: Syntax error: Encountered "drop" at line 1, column 24.
      ij> alter table test_linux drop dept;
      ERROR 42X01: Syntax error: Encountered "drop" at line 1, column 24.
      ---------------------ERROR REPORT------------------------------------------

        Issue Links

          Activity

          Kristian Waagan added a comment -

          Closing this duplicate issue. For general information about ALTER TABLE consult DERBY-396. For details about ALTER TABLE DROP COLUMN, see DERBY-1489.

          Satheesh Bandaram added a comment -

          This is a duplicate of DERBY-396.

          Shreyas Kaushik added a comment -

          What should be the expected behaviour for this? Is this documented in the SQL spec. I don't have a copy of that.

          Petr Jiricka added a comment -

          I also miss the ability to drop columns in Derby.

          Satheesh Bandaram added a comment -

          I believe this is a new feature request. Derby reference manual doesn't describe drop column.
          http://incubator.apache.org/derby/manuals/reference/sqlj26.html#HDRSII-SQLJ-81859


            People

            • Assignee:
              Unassigned
              Reporter:
              Shreyas Kaushik
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development