Uploaded image for project: 'Commons Dbcp'
  1. Commons Dbcp
  2. DBCP-385

Please update to support Java 7 and JDBC 4.1

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4
    • Fix Version/s: 2.0
    • Labels:
      None
    • Environment:

      Ubuntu 12.10/openjdk-7

      Description

      I'm currently working on the transition of all Java packages in Ubuntu from Java 6 to Java 7.

      This means we have to be able to build packages from source using openjdk-7.

      At the moment we carry a pretty heavy patch for commons-dbcp to no-op all of the new features in the JDBC 4.1 API. I know the Fedora Java team have done the same (they are the source of the patch).

      It would be great if commons-dbcp could be updated to meet these new API requirements.

      Thanks

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              javacruft James Page
            • Votes:
              4 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: