Commons Dbcp
  1. Commons Dbcp
  2. DBCP-34

[dbcp] SharedPoolDataSource raises exception while closing invalid connection

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      SharedPoolDataSource should ignore exception that happens when invalidated
      connection is being closed (inside KeyedCPDSConnectionFactory's destroyObject()
      method) when borrowing object from GenericKeyedObjectPool.

        Activity

        Mark Thomas added a comment -

        I'm not sure I understood this correctly. Working through the source, I believe the root cause is the issue I created and fixed as POOL-133. If I have mis-understood the point you were trying to make, please re-open this and correct me.


          People

          • Assignee:
            Unassigned
            Reporter:
            Vjeran Marcinko
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development