Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.0
    • Component/s: Back End
    • Labels:
      None

      Description

      Currently Daffodil insists on Java 8+. It refuses to run on Java 7.

      Some users need it to run on Java 7, and despite the possible charset decoder issues on decode errors in Java 7, they want to try it anyway.

      So some mechanism for bypassing the Java 8 check should be put in place so that the check will not be done. I would suggest an undocumented "feature" for now, as we don't really know the implications of running on Java 7, and don't test there.

        Attachments

          Activity

            People

            • Assignee:
              dfthompson Dave Thompson
              Reporter:
              mbeckerle Michael Beckerle
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: