Uploaded image for project: 'CXF'
  1. CXF
  2. CXF-8403

stax2-api version conflict in cxf-rt-ws-security

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 3.4.2
    • 3.5.0, 3.4.3, 3.3.10
    • JAX-WS Runtime
    • None
    • Unknown

    Description

      cxf-rt-ws-security transitive stax2-api-3.1.4 conflicts with cx-core stax2-api-4.2.1.

      It causes java.lang.NoSuchMethodError: org.codehaus.stax2.ri.EmptyIterator.getInstance.

      The same was already fixed in CXF-7836

      Attachments

        1. dependencies.jpg
          16 kB
          Pavel Alekhin

        Activity

          People

            ffang Freeman Yue Fang
            kuvalda Pavel Alekhin
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: