Uploaded image for project: 'CXF'
  1. CXF
  2. CXF-5312

cxf-rt-security does not work with joda time 2.x

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.7.7
    • Fix Version/s: 3.0.0-milestone1, 2.7.8
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      rt security uses joda time 1.6.2. By default the import is limited to [1.6,2). When using a higher version of joda time for other modules this requires to have two versions of joda time running.

      rt security seems to work fine with joda time 2.x so we should open the import to [1.6,3).

        Attachments

          Activity

            People

            • Assignee:
              cschneider Christian Schneider
              Reporter:
              cschneider Christian Schneider

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment