Uploaded image for project: 'CXF'
  1. CXF
  2. CXF-4324

UriInfo uninjectable

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments


    • Moderate


      Spring v3.1.1
      CXF v2.5.3
      Dozer v5.3.2
      (see attached project for further versioning details)

      I'm using CXF 2.5.3 and Spring 3.1.1.RELEASE with dozer 5.3.2.

      My restful service code maps domain objects to transfer objects, but for the life of me I cannot get UriInfo injected into my dozer custom mappers.

      The restful services are request-scoped and produced by several RequestScopeResourceFactoryS. I'm using CGLIB as the proxy implementation. My dozer mappers are defined as singletons, same thing for the dozer bean itself.

      I've tried the following:

      1. @Autowire-annotating a UriInfo instance variable => null.
      2. @Context-annotating a UriInfo instance variable => null.
      3. Written a UriInfoInjectable interface

      { @Context public void setUriInfo(UriInfo value); }

      and implemented in the service => setter is never called => null.
      4. Tried writing an CXF interceptor that loaded UriInfo into a holder bean trying to intercept in several different phases and using the three last approaches => null.

      I attached a sample project that exhibits the problem.

      1. mvn clean tomcat:run
      2. http://localhost:8080/uriinfofail/

      Note the TRACE messages saying that uriInfo is null.



          This comment will be Viewable by All Users Viewable by All Users


            Unassigned Unassigned
            ceineke Chris Eineke




                Issue deployment