CXF
  1. CXF
  2. CXF-4029

cxf-codegen-plugin doesn't generate any code code when the wsdl parameter is an url

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.1
    • Fix Version/s: 2.5.2
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      The maven cxf-codegen-plugin doesn't generate any code when the wsdl parameter is an url. This bug seems to be introduced in 2.5.1, 2.5.0 is working ok.

      Output in 2.5.1 (Nothing is generated):

      [INFO] Scanning for projects...
      [INFO] ------------------------------------------------------------------------
      [INFO] Building example
      [INFO]    task-segment: [generate-sources]
      [INFO] ------------------------------------------------------------------------
      [INFO] [cxf-codegen:wsdl2java {execution: generate-sources}]
      [INFO] Nothing to generate
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESSFUL
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 2 seconds
      [INFO] Finished at: Fri Jan 13 14:12:34 CET 2012
      [INFO] Final Memory: 19M/169M
      [INFO] --------------------------------------------------------------------
      
      Output in 2.5.0 (code is generated ok):
      [INFO] Scanning for projects...
      [INFO] ------------------------------------------------------------------------
      [INFO] Building example
      [INFO]    task-segment: [generate-sources]
      [INFO] ------------------------------------------------------------------------
      [INFO] [cxf-codegen:wsdl2java {execution: generate-sources}]
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESSFUL
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 5 seconds
      [INFO] Finished at: Fri Jan 13 14:15:14 CET 2012
      [INFO] Final Memory: 26M/171M
      [INFO] -------------------------------------------------------------------
      

      Pom:

      <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      	xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
      	<modelVersion>4.0.0</modelVersion>
      	<groupId>com.example</groupId>
      	<artifactId>cxf</artifactId>
      	<version>0.0.1-SNAPSHOT</version>
      	<packaging>jar</packaging>
      	<name>example</name>
      
      	<build>
      		<plugins>
      			<plugin>
      				<groupId>org.apache.cxf</groupId>
      				<artifactId>cxf-codegen-plugin</artifactId>
      				<version>2.5.1</version>
      				<executions>
      					<execution>
      						<id>generate-sources</id>
      						<phase>generate-sources</phase>
      						<configuration>
      							<sourceRoot>${basedir}/src/main/generated/</sourceRoot>
      							<wsdlOptions>
      								<wsdlOption>
      									<wsdl>http://www.webservicex.net/CurrencyConvertor.asmx?WSDL</wsdl>
      								</wsdlOption>
      							</wsdlOptions>
      						</configuration>
      						<goals>
      							<goal>wsdl2java</goal>
      						</goals>
      					</execution>
      				</executions>
      			</plugin>
      		</plugins>
      	</build>
      </project>
      

        Issue Links

          Activity

          Sven Rienstra created issue -
          Benson Margulies added a comment -

          this is a duplicate of another JIRA and it is indeed a real bug. I'll mark the duplication soon.

          Benson Margulies made changes -
          Field Original Value New Value
          Link This issue relates to CXF-3964 [ CXF-3964 ]
          Benson Margulies added a comment - - edited

          It turns out that the other report consists of comments attached to the JIRA I was working on when I caused this problem. I've linked to it, there's a test case attached.

          Daniel Kulp made changes -
          Description The maven cxf-codegen-plugin doesn't generate any code when the wsdl parameter is an url. This bug seems to be introduced in 2.5.1, 2.5.0 is working ok.

          Output in 2.5.1 (Nothing is generated):
          [INFO] Scanning for projects...
          [INFO] ------------------------------------------------------------------------
          [INFO] Building example
          [INFO] task-segment: [generate-sources]
          [INFO] ------------------------------------------------------------------------
          [INFO] [cxf-codegen:wsdl2java {execution: generate-sources}]
          [INFO] Nothing to generate
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESSFUL
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 2 seconds
          [INFO] Finished at: Fri Jan 13 14:12:34 CET 2012
          [INFO] Final Memory: 19M/169M
          [INFO] --------------------------------------------------------------------

          Output in 2.5.0 (code is generated ok):
          [INFO] Scanning for projects...
          [INFO] ------------------------------------------------------------------------
          [INFO] Building example
          [INFO] task-segment: [generate-sources]
          [INFO] ------------------------------------------------------------------------
          [INFO] [cxf-codegen:wsdl2java {execution: generate-sources}]
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESSFUL
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 5 seconds
          [INFO] Finished at: Fri Jan 13 14:15:14 CET 2012
          [INFO] Final Memory: 26M/171M
          [INFO] -------------------------------------------------------------------

          Pom:
          <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
          <modelVersion>4.0.0</modelVersion>
          <groupId>com.example</groupId>
          <artifactId>cxf</artifactId>
          <version>0.0.1-SNAPSHOT</version>
          <packaging>jar</packaging>
          <name>example</name>

          <build>
          <plugins>
          <plugin>
          <groupId>org.apache.cxf</groupId>
          <artifactId>cxf-codegen-plugin</artifactId>
          <version>2.5.1</version>
          <executions>
          <execution>
          <id>generate-sources</id>
          <phase>generate-sources</phase>
          <configuration>
          <sourceRoot>${basedir}/src/main/generated/</sourceRoot>
          <wsdlOptions>
          <wsdlOption>
          <wsdl>http://www.webservicex.net/CurrencyConvertor.asmx?WSDL&lt;/wsdl>
          </wsdlOption>
          </wsdlOptions>
          </configuration>
          <goals>
          <goal>wsdl2java</goal>
          </goals>
          </execution>
          </executions>
          </plugin>
          </plugins>
          </build>
          </project>
          The maven cxf-codegen-plugin doesn't generate any code when the wsdl parameter is an url. This bug seems to be introduced in 2.5.1, 2.5.0 is working ok.

          Output in 2.5.1 (Nothing is generated):
          {code}
          [INFO] Scanning for projects...
          [INFO] ------------------------------------------------------------------------
          [INFO] Building example
          [INFO] task-segment: [generate-sources]
          [INFO] ------------------------------------------------------------------------
          [INFO] [cxf-codegen:wsdl2java {execution: generate-sources}]
          [INFO] Nothing to generate
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESSFUL
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 2 seconds
          [INFO] Finished at: Fri Jan 13 14:12:34 CET 2012
          [INFO] Final Memory: 19M/169M
          [INFO] --------------------------------------------------------------------

          Output in 2.5.0 (code is generated ok):
          [INFO] Scanning for projects...
          [INFO] ------------------------------------------------------------------------
          [INFO] Building example
          [INFO] task-segment: [generate-sources]
          [INFO] ------------------------------------------------------------------------
          [INFO] [cxf-codegen:wsdl2java {execution: generate-sources}]
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESSFUL
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 5 seconds
          [INFO] Finished at: Fri Jan 13 14:15:14 CET 2012
          [INFO] Final Memory: 26M/171M
          [INFO] -------------------------------------------------------------------
          {code}

          Pom:

          {code:xml}
          <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
          <modelVersion>4.0.0</modelVersion>
          <groupId>com.example</groupId>
          <artifactId>cxf</artifactId>
          <version>0.0.1-SNAPSHOT</version>
          <packaging>jar</packaging>
          <name>example</name>

          <build>
          <plugins>
          <plugin>
          <groupId>org.apache.cxf</groupId>
          <artifactId>cxf-codegen-plugin</artifactId>
          <version>2.5.1</version>
          <executions>
          <execution>
          <id>generate-sources</id>
          <phase>generate-sources</phase>
          <configuration>
          <sourceRoot>${basedir}/src/main/generated/</sourceRoot>
          <wsdlOptions>
          <wsdlOption>
          <wsdl>http://www.webservicex.net/CurrencyConvertor.asmx?WSDL&lt;/wsdl>
          </wsdlOption>
          </wsdlOptions>
          </configuration>
          <goals>
          <goal>wsdl2java</goal>
          </goals>
          </execution>
          </executions>
          </plugin>
          </plugins>
          </build>
          </project>
          {code}
          Daniel Kulp added a comment -


          Verified that only "File" wsdl locations were left in the effective list of wsdl's to process.

          Daniel Kulp made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Daniel Kulp [ dkulp ]
          Fix Version/s 2.5.2 [ 12319249 ]
          Resolution Fixed [ 1 ]
          Daniel Kulp made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Daniel Kulp
              Reporter:
              Sven Rienstra
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development