Description
ObjectNames for counters look like that:
org.apache.cxf:bus.id=cxf945122723,type=Performance.Counter.Server,service="
{http://apache.org/hello_world_soap_http}SOAPService",port="
{http://apache.org/hello_world_soap_http}SoapPort",operation="
{http://apache.org/hello_world_soap_http}sayHi"
Having them mapped to qnames is unnecessary and only makes ONs long and hard to read/manage and I think it would be better if they looked like this:
org.apache.cxf:bus.id=cxf945122723,type=Performance.Counter.Server,service="
{http://apache.org/hello_world_soap_http}SOAPService",port="SoapPort",operation="sayHi"
I am proposing the attached patch to fix this.