Uploaded image for project: 'Apache Curator'
  1. Apache Curator
  2. CURATOR-526

Error logged for valid config - "Invalid config event received: {properties}"

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.1
    • Fix Version/s: 5.1.1
    • Component/s: Framework
    • Labels:
      None

      Description

      Curator Framework v4.0.1 - EnsembleTracker.processConfigData(byte[] data) (Ln: 157)- seems to be logging error for valid configs when the config string obtained from Zookeeper does not have the client info in it. 

      As per the docs the config string should conform to below formats:

      server_config or server_config;client_config where server_config is host:port:port or host:port:port:type and client_config is port or host:port

      In our case it conforms to the first pattern i.e. server_config with host:port:port:type

        Attachments

          Activity

            People

            • Assignee:
              eolivelli Enrico Olivelli
              Reporter:
              raj.gzmail@gmail.com Rajesh Singh

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 1.5h
                1.5h

                  Issue deployment