Details
-
Bug
-
Status: Resolved
-
Major
-
Resolution: Fixed
-
None
-
None
-
None
-
None
Description
The Javadoc for CSVFormat.isCommentingDisabled() says:
/** * Specifies whether comments are supported by this format. * * @return <tt>true</tt> is comments are supported, <tt>false</tt> otherwise */
however the method actually does the opposite, as the name suggests.
Now we could just fix the Javadoc, but given that the other isXXX methods return a positive result this would be inconsistent.
Also, it's generally better to return positive setting.
So I think renaming the method as "isCommentingEnabled" - and fixing the method code - would be better.