Uploaded image for project: 'Crunch'
  1. Crunch
  2. CRUNCH-366

Include scala base version in scrunch artifact

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.10.0, 0.8.3
    • Component/s: Scrunch
    • Labels:
      None

      Description

      CRUNCH-225 did most of the work to flex compiling against Scala 2.9 vs. 2.10, but the released artifacts are still against one version or the other and not both. Also, typically in the Scala community the Scala base version is included in the artifact so that it's clear exactly which Scala version it's compatible with.

      This is a simple change:
      1. Change artifactId to be crunch-scrunch_${scala.base.version}
      2. Add <scala.base.version>2.9</scala.base.version> to the scala-2.9.2 profile
      3. Add <scala.base.version>2.10</scala.base.version> to the scala-2.10 profile

      Once these changes were made, when releasing scrunch you just have to release twice, once for each profile.

        Attachments

          Activity

            People

            • Assignee:
              jwills Josh Wills
              Reporter:
              trenchguinea Sean Griffin
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: