Uploaded image for project: 'CouchDB'
  1. CouchDB
  2. COUCHDB-2556

CentOS install docs needs in update

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Won't Fix
    • None
    • None
    • Documentation
    • None

    Description

      From IRC:

      [08:37:31] MasterGberry: Where is the most up to date instllation instructions for CouchDB and CentOS? the page here http://docs.couchdb.org/en/latest/install/unix.html seems to be missing some information about how to get some of the dependencies
      [08:37:40] MasterGberry: none of the erlang stuff exists
      [08:38:16] Kxepal: MasterGberry: what's missed?
      [08:38:30] Kxepal: let's fix that (:
      [08:39:14] MasterGberry: none of the erlang packages exist by default repos
      [08:39:36] Kxepal: that's cannot be
      [08:39:36] MasterGberry: I ran "sudo yum install autoconf autoconf-archive automake curl-devel erlang-asn1 erlang-erts erlang-eunit erlang-os_mon erlang-xmerl help2man libicu-devel libtool perl-Test-Harness"
      [08:39:56] MasterGberry: This was the output https://gist.github.com/mastergberry/0e48977aabfd894a682c
      [08:40:32] MasterGberry: Using CentOS release 6.6 (Final)
      [08:46:50] Kxepal: hm...try to erlang solutions repo https://www.erlang-solutions.com/downloads/download-erlang-otp or follow instruction from https://github.com/wendall911/couchdb-rpm .if any works, docs needs to be updated.
      [08:54:33] MasterGberry: Kxepal ok let me give it a quick shot
      [08:59:05] MasterGberry: Kxepal add "yum localinstall http://packages.erlang-solutions.com/erlang-solutions-1.0-1.noarch.rpm" (or latest version found here https://www.erlang-solutions.com/downloads/download-erlang-otp) to your documentation
      [08:59:22] MasterGberry: Should also just make the yum install 1 long line so it's easier for people to copy and paste
      [09:01:24] Kxepal: MasterGberry: cool and good idea. is that enough to make couchdb on centos so far?
      [09:02:00] MasterGberry: I have to do the spidermonkey stuff now
      [09:02:08] MasterGberry: and iirc last time that was a pain in the ass...i couldnt get it to compile from source properly
      [09:02:14] MasterGberry: trying to see if i can find the rpm i ended up using
      [09:07:50] MasterGberry: bah found something for centos7 but not 6
      [09:10:39] MasterGberry: oh im dumb
      [09:11:44] MasterGberry: Why doesnt' wendall911 just post the actual rpm instead of making us build it :/
      [09:14:44] Kxepal: dont know, but this is a good subject for couchdb-rpm issue (:
      [09:15:04] MasterGberry knows nothing about RPM's, dont ask
      [09:16:26] MasterGberry: Kinda wish it was easier to just build all this stuff though
      [09:17:19] MasterGberry hopes that the spidermonkey stuff is installing right
      [09:25:17] MasterGberry: Notes to self installed using https://github.com/wendall911/js185 , had no issues installing final rpm for js-1.8.5-15.el6.x86_64.rpm, needed to "yum install readline-devel" to make js-devel-1.8.5-15.el6.x86_64.rpm install properly
      [09:25:56] MasterGberry: oh and had to download the actual tar.gz to the correct location specified in the instructions (not 100% clear) found here http://www.filewatcher.com/m/js185-1.0.0.tar.gz.6164605-0.html
      [09:28:09] MasterGberry: here comes the fun part...fixing the ./configure to work
      [10:08:50] MasterGberry: ./configure --with-erlang=/usr/lib64/erlang/usr/include/
      [10:11:45] MasterGberry: Kxepal ok so from my instructions in this chat
      [10:11:51] MasterGberry: i got it to install properly in that order
      [10:12:07] MasterGberry: step 2.1.4 and 2.1.5 are out of order
      [10:12:15] MasterGberry: well some of it at least
      [10:12:19] MasterGberry: u should be making the user first
      [10:12:23] MasterGberry: then trying to run the couchdb setup
      [10:12:37] MasterGberry: oh and obv after ./configure just the make && make install
      [10:13:39] MasterGberry: no idea what --gecos is...but thats not an option
      [10:15:43] MasterGberry: adduser --system --home /usr/local/var/lib/couchdb --no-create-home --shell /bin/bash -c "CouchDB Administrator" couchdb
      [10:15:53] MasterGberry: that is what i ran, not sure if its the right solution or not tho
      [10:18:08] Kxepal: MasterGberry: > The "GECOS" field of /etc/passwd is for comments, usually for the full name of the user. // never actually seen this before
      [10:19:23] Kxepal: MasterGberry: if it works and those in docs doesn't that makes it right anyway. thanks, I'll sort these bits to correct the install docs. btw, you may also send us pull request with all the changes (;
      [10:20:07] MasterGberry: also don't seem to have the couchdb init.d script installed for some reason :/
      [10:20:31] Kxepal: it may be in /usr/local/etc/init.d/...
      [10:20:47] MasterGberry: nope
      [10:20:55] MasterGberry: lets see if i can find it..
      [10:21:17] MasterGberry: ./usr/local/etc/rc.d/couchdb

      Attachments

        Activity

          People

            Unassigned Unassigned
            kxepal Alexander Shorin
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: