CouchDB
  1. CouchDB
  2. COUCHDB-1236

"Named Document Replication" hangs after a number of runs

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.11.2, 1.0.2
    • Fix Version/s: None
    • Component/s: Replication
    • Labels:
      None
    • Environment:

      CentOS 5.5

    • Skill Level:
      Dont Know

      Description

      I want to periodically update a target datebase using "named document replication".
      In my tests I have about 480 documents in the source database (mostly containing attachments) i want to replicate. Additionally I compact the target database after each run.
      Please see the attached script (20110729_testScripts.zip) for details.

      After a number of runs (in my last test after 8 runs) the replicator hangs - forever. I need to restart the CouchDB server before a new replication is possible.

        Activity

        Hans-D. Böhlau created issue -
        Hans-D. Böhlau made changes -
        Field Original Value New Value
        Attachment 20110729_testScripts.zip [ 12488201 ]
        Hans-D. Böhlau made changes -
        Description I want to periodically update a target datebase using "named document replication".
        In my tests I have about 480 documents in the source database (mostly containing attachments) i want to replicate. Additionally I compact the target database after each run.
        Please see the attached script for details.

        After a number of runs (in my last test after 8 runs) the replicator hangs - forever. I need to restart the CouchDB server before a new replication is possible.

        I want to periodically update a target datebase using "named document replication".
        In my tests I have about 480 documents in the source database (mostly containing attachments) i want to replicate. Additionally I compact the target database after each run.
        Please see the attached script (20110729_testScripts.zip) for details.

        After a number of runs (in my last test after 8 runs) the replicator hangs - forever. I need to restart the CouchDB server before a new replication is possible.

        Jan Lehnardt added a comment -

        Can you test this against 1.1.x?

        Alexander Shorin added a comment -

        Fail to reproduce such behaviour using provided test scripts against 1.0.5, 1.1.3 and 1.3.1 releases, replicating 512 documents with various content (I'd modified include_docs.sh to specify my own doc ids). Feel free to reopen if this issue still happens for you.

        Alexander Shorin made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Hans-D. Böhlau
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development