Uploaded image for project: 'Continuum'
  1. Continuum
  2. CONTINUUM-2669

org.apache.continuum.distributed.transport.slave.SlaveBuildAgentTransportClient

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.3.7
    • Fix Version/s: 1.4.2
    • Component/s: Distributed Builds
    • Labels:
      None
    • Environment:
      Linux

      Description

      I have continuum 1.3.7, working on tomcat 7.0.20, to enable distributed build management, I have followed the steps to configure the agent as mentioned in the specified link http://continuum.apache.org/docs/1.3.4/administrator_guides/distributed-builds.html

      After all the configuration and the settings, I have to below issue in the log

      2011-10-12 04:10:42,274 [http-bio-/10.128.214.83-8080-exec-5] INFO org.apache.continuum.distributed.transport.slave.SlaveBuildAgentTransportClient - Checking if project group is in queue
      2011-10-12 04:10:42,284 [http-bio-/10.128.214.83-8080-exec-5] INFO org.apache.continuum.distributed.transport.slave.SlaveBuildAgentTransportClient - Retrieving build size of agent
      2011-10-12 04:10:42,284 [pool-8-thread-1] INFO org.apache.continuum.builder.distributed.executor.DistributedBuildProjectTaskExecutor - initializing buildContext
      2011-10-12 04:10:42,354 [pool-8-thread-1] ERROR org.apache.continuum.distributed.transport.slave.SlaveBuildAgentTransportClient - Failed to build projects.
      java.lang.RuntimeException: Could not execute RPC method buildProjects
      at com.atlassian.xmlrpc.RPCCallMethodInterceptor.invoke(RPCCallMethodInterceptor.java:67)
      at $Proxy6.buildProjects(Unknown Source)
      at org.apache.continuum.distributed.transport.slave.SlaveBuildAgentTransportClient.buildProjects(SlaveBuildAgentTransportClient.java:78)
      at org.apache.continuum.builder.distributed.executor.DistributedBuildProjectTaskExecutor.executeTask(DistributedBuildProjectTaskExecutor.java:113)
      at org.apache.continuum.builder.distributed.executor.ThreadedDistributedBuildTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedDistributedBuildTaskQueueExecutor.java:118)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: org.apache.xmlrpc.common.XmlRpcExtensionException: Null values aren't supported, if isEnabledForExtensions() == false
      at org.apache.xmlrpc.common.TypeFactoryImpl.getSerializer(TypeFactoryImpl.java:115)
      at com.atlassian.xmlrpc.BinderTypeFactory.getSerializer(BinderTypeFactory.java:64)
      at org.apache.xmlrpc.serializer.MapSerializer.writeValue(MapSerializer.java:70)
      at org.apache.xmlrpc.serializer.MapSerializer.writeEntry(MapSerializer.java:64)
      at org.apache.xmlrpc.serializer.MapSerializer.writeData(MapSerializer.java:81)
      at org.apache.xmlrpc.serializer.MapSerializer.write(MapSerializer.java:88)
      at org.apache.xmlrpc.serializer.ObjectArraySerializer.writeObject(ObjectArraySerializer.java:50)
      at org.apache.xmlrpc.serializer.ObjectArraySerializer.writeData(ObjectArraySerializer.java:55)
      at org.apache.xmlrpc.serializer.ObjectArraySerializer.write(ObjectArraySerializer.java:62)
      at org.apache.xmlrpc.serializer.XmlRpcWriter.writeValue(XmlRpcWriter.java:172)
      at org.apache.xmlrpc.serializer.XmlRpcWriter.write(XmlRpcWriter.java:77)
      at org.apache.xmlrpc.client.XmlRpcStreamTransport$ReqWriterImpl.write(XmlRpcStreamTransport.java:67)
      at org.apache.xmlrpc.client.XmlRpcHttpTransport$ByteArrayReqWriter.<init>(XmlRpcHttpTransport.java:23)
      at org.apache.xmlrpc.client.XmlRpcHttpTransport.newReqWriter(XmlRpcHttpTransport.java:106)
      at org.apache.xmlrpc.client.XmlRpcStreamTransport.sendRequest(XmlRpcStreamTransport.java:139)
      at org.apache.xmlrpc.client.XmlRpcHttpTransport.sendRequest(XmlRpcHttpTransport.java:94)
      at org.apache.xmlrpc.client.XmlRpcSunHttpTransport.sendRequest(XmlRpcSunHttpTransport.java:44)
      at org.apache.xmlrpc.client.XmlRpcClientWorker.execute(XmlRpcClientWorker.java:53)
      at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:166)
      at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:157)
      at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:146)
      at com.atlassian.xmlrpc.RPCCallMethodInterceptor.invoke(RPCCallMethodInterceptor.java:62)
      ... 9 more
      2011-10-12 04:10:42,354 [pool-8-thread-1] ERROR org.apache.continuum.builder.distributed.executor.DistributedBuildProjectTaskExecutor - Error occurred while building task
      java.lang.Exception: Failed to build projects.
      at org.apache.continuum.distributed.transport.slave.SlaveBuildAgentTransportClient.buildProjects(SlaveBuildAgentTransportClient.java:84)
      at org.apache.continuum.builder.distributed.executor.DistributedBuildProjectTaskExecutor.executeTask(DistributedBuildProjectTaskExecutor.java:113)
      at org.apache.continuum.builder.distributed.executor.ThreadedDistributedBuildTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedDistributedBuildTaskQueueExecutor.java:118)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.RuntimeException: Could not execute RPC method buildProjects
      at com.atlassian.xmlrpc.RPCCallMethodInterceptor.invoke(RPCCallMethodInterceptor.java:67)
      at $Proxy6.buildProjects(Unknown Source)
      at org.apache.continuum.distributed.transport.slave.SlaveBuildAgentTransportClient.buildProjects(SlaveBuildAgentTransportClient.java:78)
      ... 7 more
      Caused by: org.apache.xmlrpc.common.XmlRpcExtensionException: Null values aren't supported, if isEnabledForExtensions() == false
      at org.apache.xmlrpc.common.TypeFactoryImpl.getSerializer(TypeFactoryImpl.java:115)
      at com.atlassian.xmlrpc.BinderTypeFactory.getSerializer(BinderTypeFactory.java:64)
      at org.apache.xmlrpc.serializer.MapSerializer.writeValue(MapSerializer.java:70)
      at org.apache.xmlrpc.serializer.MapSerializer.writeEntry(MapSerializer.java:64)
      at org.apache.xmlrpc.serializer.MapSerializer.writeData(MapSerializer.java:81)
      at org.apache.xmlrpc.serializer.MapSerializer.write(MapSerializer.java:88)
      at org.apache.xmlrpc.serializer.ObjectArraySerializer.writeObject(ObjectArraySerializer.java:50)
      at org.apache.xmlrpc.serializer.ObjectArraySerializer.writeData(ObjectArraySerializer.java:55)
      at org.apache.xmlrpc.serializer.ObjectArraySerializer.write(ObjectArraySerializer.java:62)
      at org.apache.xmlrpc.serializer.XmlRpcWriter.writeValue(XmlRpcWriter.java:172)
      at org.apache.xmlrpc.serializer.XmlRpcWriter.write(XmlRpcWriter.java:77)
      at org.apache.xmlrpc.client.XmlRpcStreamTransport$ReqWriterImpl.write(XmlRpcStreamTransport.java:67)
      at org.apache.xmlrpc.client.XmlRpcHttpTransport$ByteArrayReqWriter.<init>(XmlRpcHttpTransport.java:23)
      at org.apache.xmlrpc.client.XmlRpcHttpTransport.newReqWriter(XmlRpcHttpTransport.java:106)
      at org.apache.xmlrpc.client.XmlRpcStreamTransport.sendRequest(XmlRpcStreamTransport.java:139)
      at org.apache.xmlrpc.client.XmlRpcHttpTransport.sendRequest(XmlRpcHttpTransport.java:94)
      at org.apache.xmlrpc.client.XmlRpcSunHttpTransport.sendRequest(XmlRpcSunHttpTransport.java:44)
      at org.apache.xmlrpc.client.XmlRpcClientWorker.execute(XmlRpcClientWorker.java:53)
      at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:166)
      at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:157)
      at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:146)
      at com.atlassian.xmlrpc.RPCCallMethodInterceptor.invoke(RPCCallMethodInterceptor.java:62)
      ... 9 more

      Please help, Am I missing anything related to configuration?

      Thanks for your help......
      Krishna

        Activity

        brettporter Brett Porter added a comment -

        I've seen this on occasion but can't reproduce it. I'll put some logging in to the next version to try and identify where the null comes from.

        brettporter Brett Porter added a comment -

        One possibility is when the username used to trigger is null

        brettporter Brett Porter added a comment -

        Logging in place to catch this if there are others, and added a guard for the username.


          People

          • Assignee:
            brettporter Brett Porter
            Reporter:
            kkalal Krishna
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development