Continuum
  1. Continuum
  2. CONTINUUM-1521

NullPointerException in StarTeam changelog command

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1-beta-3
    • Fix Version/s: 1.2
    • Component/s: SCM
    • Labels:
      None
    • Environment:
      Linux RedHat ES3

      Description

      I get a NullPointerException when trying to build projects:
      Caused by: java.lang.NullPointerException
      at org.apache.maven.scm.provider.starteam.command.changelog.StarteamChangeLogCommand.executeChangeLogCommand(StarteamChangeLogCommand.java:57)
      at org.apache.maven.scm.command.changelog.AbstractChangeLogCommand.executeCommand(AbstractChangeLogCommand.java:101)
      at org.apache.maven.scm.command.update.AbstractUpdateCommand.executeCommand(AbstractUpdateCommand.java:75)
      at org.apache.maven.scm.command.AbstractCommand.execute(AbstractCommand.java:58)
      ... 16 more

      These same projects actually built OK several times, and now I'm getting this exception for all projects. This persists across restarts of continuum.
      These projects also build OK on continuum 1.0.3

        Issue Links

          Activity

          Stephen Cooper added a comment -

          Playing a bit more with this...I have found out some things which may help.

          The project definition was set up to use the SCM credentials cache. When I disabled that option and re-entered my password, then the build started working.

          So, this bug might need to be re-worked and split into two separate issues:
          1) get a better error message than NullPointerException for whatever was wrong with the SCM credential cache (minor)
          2) SCM credential cache not working. (this one)

          Stephen Cooper added a comment -

          More information - this issue re-occurs with working projects.

          I edit the project, enter my StarTeam password, the build works. Then, a while later, the build breaks with this exception. I go in and re-enter my password and the build works again.

          Irritating.

          Stephen Cooper added a comment -

          This boils down to Continuum "forgetting" the StarTeam password periodically.

          After about 2 or three builds, I'll get a Build Error report with the above null pointer, and I have to go in and edit the project and re-enter my StarTeam password. This makes continuum 1.1 unusable for StarTeam projects.

          Dan Tran added a comment -

          I dont think credential cache would not work for starteam at all since Borland does not expose its internal credential structure similar
          to the way svn and cvs.

          adn therefore Continuum must not apply credential cache on Starteam provider.

          Stephen Cooper added a comment - - edited

          Yeah, the credential cache wasn't doing much for StarTeam. First thing I did for these projects was to turn it off.

          However, having entered the password in the Web UI, I would expect continuum to keep the password and use it for each build. As things stand, the password is lost after about two or three builds.

          Continuum 1.0.3 doesn't behave this way, so this is a regressive error.

          Maybe having enabled the password cache the first time is what is causing this? But no, this is happening for all projects, and some of them I never enabled the password cache for.

          Dan Tran added a comment -

          I trace it down to the NPE and fix it at

          http://svn.apache.org/viewvc/maven/scm/trunk/maven-scm-providers/maven-scm-provider-starteam/src/main/java/org/apache/maven/scm/provider/starteam/command/changelog/StarteamChangeLogCommand.java?view=markup&pathrev=607771

          Please build maven-scm-provider-starteam from trunk and replace the one under continuum.home/apps/continuum/webapp/WEB-INF/lib and report back the result. Thanks

          Olivier Lamy (*$^¨%`£) added a comment -

          upgrade maven-scm version to 1.1-SNAPSHOT in rev 608083.

          Olivier Lamy (*$^¨%`£) added a comment -

          update to last wagon-scm fix it.

          Dan Tran added a comment -

          you mean maven-scm right?

          Olivier Lamy (*$^¨%`£) added a comment -

          yes ( funny typo )


            People

            • Assignee:
              Olivier Lamy (*$^¨%`£)
              Reporter:
              Stephen Cooper
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development