Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: ManifoldCF 0.5
    • Fix Version/s: ManifoldCF 0.5
    • Component/s: Documentation
    • Labels:
      None

      Description

      The Japanese part of the site is corrupted when published. It seems that Forrest corrupts certain utf-8 characters. I've checked the latest Forrest and it doesn't help, so I've created FOR-1231 to track this.

        Issue Links

          Activity

          Hitoshi Ozawa added a comment -

          I'm not sure about Apache's documentation upload procedure or the environment, but "forrest site" seems to generate the site correctly. Is it possible to just upload the generated files? It's necessary to install Japanese fonts to generate the pdf correctly. Is it possible to generate the pdf locally and upload the file or it is possible to install fonts for the Apache ManifoldCF project site?

          Karl Wright added a comment -

          "forrest site" is what is used to build the files that I'm browsing, and those are the ones copied to the external site. If the files are being generated correctly for you, it is likely because your system locale is different from mine. Forrest seems to incorrectly use the system locale in a number of places and that's how it is broken.

          Hitoshi Ozawa added a comment -

          I'm running on a Japanese OS. That may be the reason.
          I can attach the generated site files if that's an alternative temporary solution.

          Karl Wright added a comment -

          I can attach the generated site files if that's an alternative temporary solution.

          I'd like to look at them as a sanity check in any case, to be sure they render OK on my system. Can you attach just one, say for instance ja_JP/index.html, so that I can confirm it works right here?

          If there's a way to change the locale for forrest alone that would be a better solution. But I still can't get the PDF to generate properly. See CONNECTORS-387. Maybe you will have better luck. Posting to the forrest user's list sounds like a good idea for that one.

          Karl Wright added a comment -

          This page for Cocoon describes how to set the locale on JVM startup:

          http://wiki.apache.org/cocoon/SettingTheJvmLocale

          Interestingly they admit that the stuff will be broken unless the "proper" locale is set. Unfortunately there is no locale that forces utf-8 encoding, I think.

          Karl Wright added a comment -

          I tried setting the locale for the ant invocation that Forrest does, but that doesn't help.

          Karl Wright added a comment -

          I tried setting the locale for the ant invocation that Forrest does, but that doesn't help.

          Karl Wright added a comment -

          r1232822 uses JAVA_TOOL_OPTIONS to set -Dfile.encoding=UTF8 for the JVMS that forrest starts.

          Hitoshi Ozawa added a comment -

          Great, but the Japanese characters in the site is still corrupted.

          Karl Wright added a comment -

          The site mirrors every 24 hours. Will take a bit longer to get out there. When it does you will need to refresh the pages in your browser to insure they aren't cached by your browser.

          Karl Wright added a comment -

          It has now updated.


            People

            • Assignee:
              Karl Wright
              Reporter:
              Karl Wright
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development