Uploaded image for project: 'Commons Compress'
  1. Commons Compress
  2. COMPRESS-443

Add a test that verifies Commons Compress is usable as an OSGi bundle

    XMLWordPrintableJSON

    Details

    • Type: Test
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.16
    • Fix Version/s: 1.17
    • Component/s: Build
    • Labels:
      None

      Description

      As COMPRESS-442  COMPRESS-396 and COMPRESS-199 have shown it is way too easy for us to break the OSGi manifest without anybody noticing.

      See https://lists.apache.org/thread.html/1bb1d342900ed78d7e280d9321ea38900c10c99e03241aaa11ceb6f9@%3Cdev.commons.apache.org%3E for some hints how a test could be written.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              bodewig Stefan Bodewig
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: