Details
-
Improvement
-
Status: Closed
-
Major
-
Resolution: Won't Fix
-
3.2
-
None
-
None
-
None
Description
The javadocs in DefaultedMap is very inconsistent. It speaks
of factory
when a transformer is meant, it speaks of transformer when value is
meant and that sort of stuff.
Besides, it would be much cleaner to declare 'value' of type
Transformer, and create a transformer every time, except when one is
passed (the instanceof checks are wrong anyway), (I'd rename it to
transformer, too).
Even nicer would be to split up the constructor(s) into one
that takes a
value, and one that takes a Transformer, no instanceof checks needed,
much cleaner code, generification is almost trivial