Uploaded image for project: 'CloudStack'
  1. CloudStack
  2. CLOUDSTACK-9592

Empty responses from site to site connection status are not handled propertly

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 4.8.0
    • Fix Version/s: 4.8.1
    • Component/s: Network Controller
    • Security Level: Public (Anyone can view this level - this is the default.)
    • Labels:
      None
    • Environment:
      Any Hypervisor

      Description

      vpn connection status gives responses like the below sometimes

      Processing: { Ans: , MgmtId: 7203499016310, via: 1(10.147.28.37), Ver: v1, Flags: 110, [{"com.cloud.agent.api.CheckS2SVpnConnectionsAnswer":{"ipToConnected":{},"ipToDetail":{},"details":"","result":true,"wait":0}}] }
      2016-09-27 08:52:19,211 DEBUG [c.c.a.t.Request] (RouterStatusMonitor-1:ctx-c20f391d) (logid:c217239d) Seq 1-2315413158421863581: Received:

      { Ans: , MgmtId: 7203499016310, via: 1(10.147.28.37), Ver: v1, Flags: 110, { CheckS2SVpnConnectionsAnswer }

      In the above scenario, the bug in the processing of this response assumes the connection is disconnected even though it is not disconnected and there would be two consecutive alerts in logs as well as emails even though there is not actual disconnection and reconnection

      Site-to-site Vpn Connection XYZ-VPN on router r-197-VM(id: 197) just switch from Disconnected to Connected
      Site-to-site Vpn Connection to D1 site to site VPN on router r-372-VM(id: 372) just switch from Connected to Disconnected

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                yvsubhash subhash yedugundla
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: