Uploaded image for project: 'CloudStack'
  1. CloudStack
  2. CLOUDSTACK-9557

Deploy from VMsnapshot fails with exception if source template is removed or made private

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 4.8.0
    • Fix Version/s: 4.8.1
    • Component/s: Template
    • Security Level: Public (Anyone can view this level - this is the default.)
    • Labels:
      None
    • Environment:
      Any Hypervisor

      Description

      Steps to reproduce the issue
      i) Upload a template as admin user and make sure "public" is selected when uploading it.
      ii) Now login as a user to CloudStack and deploy a VM with the template created in step i).
      iii) Create a VM snapshot as the user for the VM in step ii). Once created deploy a VM from the snapshot ( this will work as expected)
      iv) Now login as admin again , edit the template created in step i) and Uncheck "public". This is make the template as private ( or else delete the template from UI)
      v) Login as same user as in step ii) and try to create a VM from the same snapshot ( created in step iii)). This will fail now.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                yvsubhash subhash yedugundla
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: