Uploaded image for project: 'CloudStack'
  1. CloudStack
  2. CLOUDSTACK-9503

The router script times out resulting in failure of deployment

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: In Progress
    • Major
    • Resolution: Unresolved
    • 4.9.0
    • 4.9.1.0
    • Virtual Router
    • Security Level: Public (Anyone can view this level - this is the default.)
    • None
    • KVM, Xen

    Description

      When starting the virtual router in a shared network in advance zone the scripts on router time out. This happen as there are several sub-commands that are consolidated in a single command. The default timeout of 2 minutes is short.

      2016-09-09 00:06:25,016 ERROR [c.c.n.r.VirtualNetworkApplianceManagerImpl] (Work-Job-Executor-110:ctx-e8089ec7 job-5135/job-5137 ctx-c3a8da18) (logid:8aedea66) process hasn't exited
      2016-09-09 00:06:25,016 WARN [c.c.n.r.VirtualNetworkApplianceManagerImpl] (Work-Job-Executor-110:ctx-e8089ec7 job-5135/job-5137 ctx-c3a8da18) (logid:8aedea66) Command: com.cloud.agent.api.Command failed while starting virtual router
      2016-09-09 00:06:25,016 INFO [c.c.v.VirtualMachineManagerImpl] (Work-Job-Executor-110:ctx-e8089ec7 job-5135/job-5137 ctx-c3a8da18) (logid:8aedea66) The guru did not like the answers so stopping VM[DomainRouter|r-3445-VM]

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            aprateek Abhinandan Prateek
            aprateek Abhinandan Prateek

            Dates

              Created:
              Updated:

              Issue deployment