Uploaded image for project: 'CloudStack'
  1. CloudStack
  2. CLOUDSTACK-9471

Cross cluster migration did not kick in when HA is enabled and Host goes down

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 4.9.0
    • None
    • KVM
    • Security Level: Public (Anyone can view this level - this is the default.)
    • None
    • Management on CentOS 6.4 running ACS4.9
      KVM Hosts running on CentOS6.2

    Description

      Executed scenario:
      Setup: 2 KVM clusters:

      • Cluster1 - KVM-Host2 (1 host)
        • KVM-Host2 - 0 instances
      • Cluster2 - KVM-Host3, KVM-Host4 (2 hosts)
        • KVM-Host3 - 3 instances
        • KVM-Host4 - 1 instance

      all instances have service offer - Offer HA - Yes

      Steps to reproduce:

      1. Set enable.ha.storage.migration=true in Global Settings
      2. Restart management server.
      3. Shut down kvm4

      Result:
      Running instances are not migrated to suitable host in other cluster (cross-cluster migration)

      • KVM4 still having one instance, but host is in disconnected state
      • KVM2 should have received the instance but still has 0 instances.
      • KVM3 unchanged

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            bstoyanov Boris Stoyanov

            Dates

              Created:
              Updated:

              Issue deployment