Uploaded image for project: 'CloudStack'
  1. CloudStack
  2. CLOUDSTACK-8284

Primary_storage vlaue is not updating in resource_count table after VM deletion

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 4.4.2
    • Fix Version/s: None
    • Component/s: None
    • Security Level: Public (Anyone can view this level - this is the default.)
    • Labels:
      None

      Description

      I was doing some tests for checking resource limitation behavior on sub-domain, a/c and project.

      For account , I didn't set any limits. Instead I set limits on sub-domain. But this specific Primary storage limit(40GB) acted weird.
      At first in sub-domain, I created new instance (without project), and assigned 41 GB, and it successfully created VM. Then I deleted that VM with Expunge option enabled, and tried to create vm again with disk size 42, which failed with error "Maximum number of resources of type 'primary_storage' for domain id=3 has been exceeded"
      Then I gave disk size to 39GB, that also failed with same error. And now if I create any disk size its failing. There are no instances or volumes under that sub-domain.
      so which i checked resource_count table, "count" for Primary_storage was not set to zero.

      So then I logged into same domain from UI, and in "Domains" section clicked on "update resource count". After which in resource_count table "primary_storage" table value went back to zero.

      For Reference: http://comments.gmane.org/gmane.comp.apache.cloudstack.user/17008

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                adwaitpatankar adwait patankar
                Reporter:
                sonaliJ Sonali Jadhav
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: