Uploaded image for project: 'CloudStack'
  1. CloudStack

StopVMCommand reported success in spite of failing to stop a VM which got stuck during installation from an ISO



    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • pre-4.0.0
    • 4.4.3
    • Management Server
    • Security Level: Public (Anyone can view this level - this is the default.)
    • None


      Tried to deploy a VM using openSUSE-12.2-DVD-x86_64 ISO. The installation got stuck midway after 21% of Installation. I tried to stop the VM in order to start the installation from the beginning. The StopVMCmd reported success but the VM is still in running state.I expected an error to be thrown on event of StopVMCmd Failure.

      StopVMCmd Job:

      2012-09-28 15:28:27,893 DEBUG [cloud.async.AsyncJobManagerImpl] (catalina-exec-24:null) submit async job-119, details: AsyncJobVO {id:119, userId: 3, accountId: 3, sessionKey: null, instanceType: VirtualMachine, instanceId: 16, cmd: com.cloud.api.commands.StopVMCmd, cmdOriginator: null, cmdInfo:


      , cmdVersion: 0, callbackType: 0, callbackAddress: null, status: 0, processStatus: 0, resultCode: 0, result: null, initMsid: 7471666038533, completeMsid: null, lastUpdated: null, lastPolled: null, created: null}
      2012-09-28 15:28:27,896 DEBUG [cloud.async.AsyncJobManagerImpl] (Job-Executor-14:job-119) Executing com.cloud.api.commands.StopVMCmd for job-119
      2012-09-28 15:28:27,908 DEBUG [cloud.user.AccountManagerImpl] (Job-Executor-14:job-119) Access to VM[User|OpenSUSE-VM-1] granted to Acct[3-atoms] by DomainChecker
      2012-09-28 15:28:27,914 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-14:job-119) VM state transitted from :Running to Stopping with event: StopRequestedvm's original host id: 1 new host id: 1 host id before state transition: 1
      2012-09-28 15:28:27,916 WARN [cloud.vm.VirtualMachineManagerImpl] (Job-Executor-14:job-119) Unable to stop vm VM[User|OpenSUSE-VM-1]
      2012-09-28 15:28:27,921 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-14:job-119) VM state transitted from :Stopping to Running with event: OperationFailedvm's original host id: 1 new host id: 1 host id before state transition: 1
      2012-09-28 15:28:27,933 DEBUG [cloud.async.AsyncJobManagerImpl] (Job-Executor-14:job-119) Complete async job-119, jobStatus: 1, resultCode: 0, result: com.cloud.api.response.UserVmResponse@7e8c4906
      2012-09-28 15:28:27,941 DEBUG [cloud.async.AsyncJobManagerImpl] (Job-Executor-14:job-119) Done executing com.cloud.api.commands.StopVMCmd for job-119
      2012-09-28 15:28:33,211 DEBUG [cloud.async.AsyncJobManagerImpl] (catalina-exec-25:null) Async job-119 completed

      Git Info:

      Git Revision: 30b19887fd05c7694f8fdf45be9fe9b02d90b1d1
      Git URL: https://git-wip-us.apache.org/repos/asf/incubator-cloudstack.git




            chandanp Chandan Purushothama
            chandanp Chandan Purushothama
            0 Vote for this issue
            4 Start watching this issue