Uploaded image for project: 'Click'
  1. Click
  2. CLK-705

DateFormat pattern cannot be set from click-page.properties

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.0-M1
    • Component/s: extras
    • Labels:
      None

      Description

      Overriding the date format pattern in an application click-page.properties doesn't get picked up. The issue is that DateField constructor loads the date-format-pattern before the datefield is added to the Page. Since the parent Page has not been set at this stage, it isn't possible to find the parent page properties.

      Need to defer loading of the date-format-pattern until it is needed.

        Activity

        sabob Bob Schellink added a comment -

        fixed in trunk.


          People

          • Assignee:
            sabob Bob Schellink
            Reporter:
            sabob Bob Schellink
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development