Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5 M1, 1.4.1, 1.4
    • Fix Version/s: 1.5 M1
    • Component/s: extras
    • Labels:
      None
    • Environment:
      Click 1.4, 1.5-M1, Cayenne 3.0 M3, Sun JDK 1.5.0_15

      Description

      The method Cayenne method DataObjectUtils.objectForPK() used in CayenneForm cannot be resolved at runtime:

      Caused by: java.lang.NoSuchMethodError:
      org.apache.cayenne.DataObjectUtils.objectForPK(Lorg/apache/cayenne/ObjectContext;Ljava/lang/Class;Ljava/lang/Object;)Lorg/apache/cayenne/DataObject;
      10:59:06,990 INFO [STDOUT] at
      net.sf.click.extras.cayenne.CayenneForm.getDataObject(CayenneForm.java:336)

      Not sure if the issue is present on JDK 1.6, as college was not able to reproduce this error.

        Activity

        medgar Malcolm Edgar added a comment -

        Fix checked into SVN will be available in 1.5-M1


          People

          • Assignee:
            medgar Malcolm Edgar
            Reporter:
            medgar Malcolm Edgar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development