Uploaded image for project: 'Click'
  1. Click
  2. CLK-322

AutoCompleteTextField doesn't work on IE

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4
    • Fix Version/s: 1.4-RC3
    • Component/s: extras
    • Labels:
      None
    • Environment:
      Click 1.4-RC3, InternetExplorer6

      Description

      AutoCompleteTextField does not work on IE6.
      But it works on Firefox2.

        Activity

        medgar Malcolm Edgar added a comment -

        This issue is caused by the "script.aculo.us" v1.7.0 Ajax.Autocompleter IE bug. This appears to be fixed in the current version 1.8.1.

        Next release of Click 1.5 M1 should upgrade to the latest library version 1.8.1.

        The 1.7.0 fix for IE and that is to change the controls.js file line 87, "keypress" to "keyup"

        Event.observe(this.element, "keyup", this.onKeyPress.bindAsEventListener(this));

        This change has been checked into SVN and will be available in 1.4 Final

        regards Malcolm Edgar

        medgar Malcolm Edgar added a comment -

        Fixed. Note these AJAX JS libraries should be updated in the next version of Click 1.5-M1


          People

          • Assignee:
            medgar Malcolm Edgar
            Reporter:
            click_akihiro Itou Akihiro
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development