Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      1.4 RC1

      Description

      http://article.gmane.org/gmane.comp.web.click.user/1686

      I did this configuration in some old project, and it was working in some
      previous releases.

      <pages package="net.wasys.renault.page" automapping="true" >

      <page path="layout/menu.htm" classname="MenuHeaderPage"/>
      <page path="layout/header.htm" classname="MenuHeaderPage"/>

      </pages>

      But now if I call the "menu.htm" or "header.htm" pages, I got this error:

      Caused by: java.lang.ClassCastException
      at net.sf.click.ClickApp.getPageFieldArray(ClickApp.java:605)
      at net.sf.click.ClickServlet.processPageFields(ClickServlet.java:1460)

      The error is because the "object" variable is a ArrayList in this line:
      ClickApp.PageElm page = (ClickApp.PageElm) object;

        Activity

        medgar Malcolm Edgar added a comment -

        Fix checked in and will be available in release 1.4-RC3.


          People

          • Assignee:
            medgar Malcolm Edgar
            Reporter:
            rlecheta Ricardo R. Lecheta
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development