Uploaded image for project: 'Click'
  1. Click
  2. CLK-150

ActionLink.setValueObject method doesn't deal with null values properly for a particular case.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: core
    • Labels:
      None

      Description

      Symptom: When using a repeating ActionLink in a table where some of the rows don't have ids, then the id is rendered as the id of the row above.

      Root cause: ActionLink.setValueObject method should setValue to null if object is null. (Currently ignores null).

        Activity

        medgar Malcolm Edgar added a comment -

        Fix checked into SVN, will be available in release 1.2


          People

          • Assignee:
            medgar Malcolm Edgar
            Reporter:
            dfrizelle David Frizelle
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development