Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.1
    • Component/s: CLI-1.x
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: Sun

    • Bugzilla Id:
      25044

      Description

      I hav a tool that takes the following options: -p -attr.
      Both takes argument. If the user wants to specify p as the argument for attr,
      -attr p, cli throws a MissingArgumentException. This is because it sees p as an
      option rather than the argument of attr.

        Activity

        dmorris@plumcreek.com David Morris added a comment -

        Created an attachment (id=13840)
        Correct problem where an argument matches an option name and unit tests.

        This patch fixes the bug where an argument is mistaken for an option in CLI.
        This is not a bug in CLI2. Also included in the patch are tests that show this
        corrects the problem CLI and works as expected in CLI2.

        roxspring Rob Oxspring added a comment -

        Applied.

        Thanks!

        Rob

        roxspring Rob Oxspring added a comment -
            • COM-576 has been marked as a duplicate of this bug. ***
        roxspring Rob Oxspring added a comment -
            • COM-1823 has been marked as a duplicate of this bug. ***
        roxspring Rob Oxspring added a comment -
            • COM-1945 has been marked as a duplicate of this bug. ***

          People

          • Assignee:
            Unassigned
            Reporter:
            grimsell Magnus Grimsell
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development