Uploaded image for project: 'Commons CLI'
  1. Commons CLI
  2. CLI-186

Standard help text will not show mandatory arguments for first option

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.3
    • Component/s: Help formatter
    • Labels:
      None
    • Environment:

      Mac OS X 10.5 Java 6, Windows XP Java 6

      Description

      The generated help text will not show "<arg>" for the first argument added.

      See attached test case:

      Please confirm

        Issue Links

          Activity

          deexem Kristoff Kiefer added a comment -

          Underlying cause is something in OptionBuilder

          ebourg Emmanuel Bourg added a comment -

          Kristoff what version of Commons CLI did you use? I tried your test case on the trunk and besides a missing space in your test it worked fine.

          ebourg Emmanuel Bourg added a comment -

          I reproduced the issue, it requires a dedicated test case since it is tied to the initialization of a static field in OptionBuilder. The issue exists since CLI 1.1.


            People

            • Assignee:
              Unassigned
              Reporter:
              deexem Kristoff Kiefer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development