Apache Cordova
  1. Apache Cordova
  2. CB-974

ant scripts broken on latest version of Android Tools (R20)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.9.0
    • Fix Version/s: 1.9.0
    • Component/s: Android
    • Labels:
      None

      Description

      If you upgrade your Android SDK, you will get an error when building the framework about renderscript:

      /Users/bowserj/android-sdk-macosx/tools/ant/build.xml:622: The following error occurred while executing this line:
      /Users/bowserj/android-sdk-macosx/tools/ant/build.xml:642: '${renderscript.opt.level}' is not a permitted value for com.android.ant.RenderScriptTask$OptLevel
      

        Activity

        Hide
        Joe Bowser added a comment -

        Added renderscript.opt.level=O0. (Thanks @Simon)

        Show
        Joe Bowser added a comment - Added renderscript.opt.level=O0. (Thanks @Simon)

          People

          • Assignee:
            Joe Bowser
            Reporter:
            Joe Bowser
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development