Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-8696

cordova plugin add fails when there is a <dependency id="foo@1" />

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: cordova-lib
    • Labels:
      None

      Description

      You should be able to specify a version constraint within <dependency>, not just exact versions.

      This almost works right now, except we have some extra verification code that does an string comparison rather than a semver check.

        Attachments

          Activity

            People

            • Assignee:
              agrieve Andrew Grieve
              Reporter:
              agrieve Andrew Grieve
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: