Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-8582

Obscure INSTALL_FAILED_VERSION_DOWNGRADE error when installing app

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.5.0
    • Fix Version/s: None
    • Component/s: cordova-cli

      Description

      If you have a version of an app on the device already, and there is a difference in the versions, ant/android gives a pretty cryptic error.

      Installing app on device...
      
      /Users/mhartington/GithubRepos/ionic/tmp/platforms/android/cordova/node_modules/q/q.js:126
                          throw e;
                                ^
      ERROR: Failed to launch application on device: ERROR: Failed to install apk to device: 	pkg: /data/local/tmp/CordovaApp-debug.apk
      Failure [INSTALL_FAILED_VERSION_DOWNGRADE]
      
      ERROR running one or more of the platforms: Error: /Users/mhartington/GithubRepos/ionic/tmp/platforms/android/cordova/run: Command failed with exit code 8
      You may not have the required environment or OS to run this project
      

      May be beneficial to provide a better error message for why install failed.

      http://stackoverflow.com/questions/13808599/android-emulator-installation-error-install-failed-version-downgrade

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mhartington Mike Hartington
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: