Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-6359

resolveLocalFileSystemURL continues to be inconsistent, now fails specifically on Galaxy Note 3 when capturing video only

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.4.0
    • Fix Version/s: None
    • Labels:
    • Environment:

      On Mac
      Cordova info
      Current Node Version
      v0.10.25
      Current Cordova CLI Version
      3.4.0-0.1.0
      Testing with: Samsung Galaxy Note 3 (Android)...the device is NOT rooted.

      Description

      Ok this is a very strange bug. Some background first though. I have 10 test devices at my house so I can test the apps I make. Of the 10 devices 8 are android. My app works across the board on all of them flawlessly. So I already know its not something related to my set up or my code. Out of the 10 devices one specific feature seems to fail on one specific device (Galaxy Note 3). When you capture video and try to resolve the URI you will always get error core 5 every single time no matter what changes you make or conditions. Here is the code.

      navigator.device.capture.captureVideo(function(mediaFiles){
      	        var mediaFilePath = mediaFiles[0].fullPath;
      	        
                      window.resolveLocalFileSystemURL(mediaFilePath, function(){
                             ///never gets this far
                      }, function(error){
                             console.log(error.code);
                             *Always fails with error code 5*
                      });
      	    }, function(error){
      			var msg = 'Messages > captureVideo():: An error occurred during video capture: ' + error.code;
      			console.log(msg, null, 'Uh oh!');
                 });
      

      For this device and this specific scenario the path returned by capture is always something like this: *file:/storage/extSdCard/DCIM/Camera/20140327_104747.mp4* ....yes I noticed the "file:/" and have even tried replacing it with "file:///" and it still continues to fail.

      btw ...I have a lot of devices I test with with...do you guys have these kind of facilities? I have built up a rigorous excel sheet full of tests among which are all of the media type api's. I did this because resolveLocalFileSystemURL has become a problem child for me since 3.4 I have already submitted 3 bugs 1 of which was solved and actually made it to the 1.0.1 File-System update. The 2nd one is solved now too. I wouldn't care if the device this was happening to was old and was on an older firmware like 4.0.3 but this is a popular device especially in our database any help would be appreciated.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                iclelland Ian Clelland
                Reporter:
                drumaboy46 Ralph S Theart
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: