Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.2.0
    • Component/s: iOS
    • Labels:
      None
    • Environment:

      Xcode 4.5 (4G182), iOS 6 GM Seed (10a403), Cordova 2.0.0 installed... somewhere, Mac OS 10.7.4

      Description

      Trying to get an app out for iOS 6 ASAP. After cloning the git repo, building the CordovaLib project works for debugging, but when trying to Archive it, the error below occurs. It seems like it's unable to find the library after compiling it. When included in our own project, same thing occurs.

      SetOwnerAndGroup "user:staff" /Users/user/Library/Developer/Xcode/DerivedData/CordovaLib-azquqjfgcqqlhiehsxsutxwlcxbe/Build/Intermediates/ArchiveIntermediates/CordovaLib/IntermediateBuildFilesPath/UninstalledProducts/libCordova.a
      cd /docs/misc/incubator-cordova-ios/CordovaLib
      setenv PATH "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"
      /usr/sbin/chown -RH "user:staff" /Users/user/Library/Developer/Xcode/DerivedData/CordovaLib-azquqjfgcqqlhiehsxsutxwlcxbe/Build/Intermediates/ArchiveIntermediates/CordovaLib/IntermediateBuildFilesPath/UninstalledProducts/libCordova.a

      chown: /Users/user/Library/Developer/Xcode/DerivedData/CordovaLib-azquqjfgcqqlhiehsxsutxwlcxbe/Build/Intermediates/ArchiveIntermediates/CordovaLib/IntermediateBuildFilesPath/UninstalledProducts/libCordova.a: No such file or directory
      Command /usr/sbin/chown failed with exit code 1

        Issue Links

          Activity

          PJ Dillon created issue -
          Shazron Abdullah added a comment -

          See CB-1122, read the comments and run the diagnostic tool mentioned there, and post the log.

          PJ Dillon added a comment - - edited

          ------------------------------------BEGIN-------------------------------------
          Inspecting project: /docs/sulia/iOS-pg2/Sulia.xcodeproj/project.pbxproj

          --------------------------------------------------------------------------------
          Finding your project's sub-projects...

          Sub-project:

          {'path': '../incubator-cordova-ios/CordovaLib/CordovaLib.xcodeproj', 'name': 'CordovaLib.xcodeproj', 'sourceTree': '<group>'}

          --------------------------------------------------------------------------------
          Inspecting your project's Build Settings...

          Project :
          { 'Debug':

          { 'ARCHS': ['armv6', 'armv7'], 'GCC_VERSION': 'com.apple.compilers.llvm.clang.1_0', 'HEADER_SEARCH_PATHS': [ '"$(TARGET_BUILD_DIR)/usr/local/lib/include"', '"$(OBJROOT)/UninstalledProducts/include"', '"$(BUILT_PRODUCTS_DIR)"'], 'IPHONEOS_DEPLOYMENT_TARGET': '4.2', 'OTHER_LDFLAGS': [ '-weak_framework', 'CoreFoundation', '-weak_framework', 'UIKit', '-weak_framework', 'AVFoundation', '-weak_framework', 'CoreMedia', '-weak-lSystem', '-all_load', '-Obj-C'], 'USER_HEADER_SEARCH_PATHS': ''}

          ,
          'Release': { 'ARCHS': ['armv6', 'armv7'],
          'GCC_VERSION': 'com.apple.compilers.llvm.clang.1_0',
          'HEADER_SEARCH_PATHS': [ '"$(TARGET_BUILD_DIR)/usr/local/lib/include"',
          '"$(OBJROOT)/UninstalledProducts/include"',
          '"$(BUILT_PRODUCTS_DIR)"'],
          'IPHONEOS_DEPLOYMENT_TARGET': '4.2',
          'OTHER_LDFLAGS': [ '-weak_framework',
          'CoreFoundation',
          '-weak_framework',
          'UIKit',
          '-weak_framework',
          'AVFoundation',
          '-weak_framework',
          'CoreMedia',
          '-weak-lSystem',
          '-all_load',
          '-Obj-C'],
          'USER_HEADER_SEARCH_PATHS': ''}}
          Targets :
          { 'Sulia': { 'Debug':

          { 'ARCHS': '(not found)', 'GCC_VERSION': 'com.apple.compilers.llvm.clang.1_0', 'HEADER_SEARCH_PATHS': '(not found)', 'IPHONEOS_DEPLOYMENT_TARGET': '4.3', 'OTHER_LDFLAGS': [ '-weak_framework', 'CoreFoundation', '-weak_framework', 'UIKit', '-weak_framework', 'AVFoundation', '-weak_framework', 'CoreMedia', '-weak-lSystem', '-all_load', '-lsqlite3.0', '-Obj-C'], 'USER_HEADER_SEARCH_PATHS': '(not found)'}

          ,
          'Release':

          { 'ARCHS': '(not found)', 'GCC_VERSION': 'com.apple.compilers.llvm.clang.1_0', 'HEADER_SEARCH_PATHS': '(not found)', 'IPHONEOS_DEPLOYMENT_TARGET': '4.3', 'OTHER_LDFLAGS': [ '-weak_framework', 'CoreFoundation', '-weak_framework', 'UIKit', '-weak_framework', 'AVFoundation', '-weak_framework', 'CoreMedia', '-weak-lSystem', '-all_load', '-lsqlite3.0', '-Obj-C'], 'USER_HEADER_SEARCH_PATHS': '(not found)'}

          }}

          --------------------------------------------------------------------------------
          Inspecting Xcode Preferences...

          CORDOVALIB: /Users/pjdillon/Documents/CordovaLib
          Build Location Style: Unique

          --------------------------------------------------------------------------------
          Inspecting your CordovaLib's Build Settings...

          Your project is NOT using the CORDOVALIB Xcode variable (source tree).
          Path is: /docs/sulia/incubator-cordova-ios/CordovaLib/CordovaLib.xcodeproj

          { 'Project': { 'Debug':

          { 'ARCHS': ['armv6', 'armv7'], 'GCC_VERSION': 'com.apple.compilers.llvm.clang.1_0', 'IPHONEOS_DEPLOYMENT_TARGET': '4.2', 'OTHER_LDFLAGS': '(not found)', 'PUBLIC_HEADERS_FOLDER_PATH': 'include/Cordova', 'USER_HEADER_SEARCH_PATHS': ''}

          ,
          'Release': { 'ARCHS': ['armv6', 'armv7'],
          'GCC_VERSION': 'com.apple.compilers.llvm.clang.1_0',
          'IPHONEOS_DEPLOYMENT_TARGET': '4.2',
          'OTHER_LDFLAGS': '(not found)',
          'PUBLIC_HEADERS_FOLDER_PATH': 'include/Cordova',
          'USER_HEADER_SEARCH_PATHS': '(not found)'}},
          'Targets': { 'CordovaLib': { 'Debug':

          { 'ARCHS': [ 'armv6', 'armv7'], 'GCC_VERSION': 'com.apple.compilers.llvm.clang.1_0', 'IPHONEOS_DEPLOYMENT_TARGET': '4.2', 'OTHER_LDFLAGS': '(not found)', 'PUBLIC_HEADERS_FOLDER_PATH': 'include/Cordova', 'USER_HEADER_SEARCH_PATHS': '(not found)'}

          ,
          'Release': { 'ARCHS': [ 'armv6',
          'armv7'],
          'GCC_VERSION': 'com.apple.compilers.llvm.clang.1_0',
          'IPHONEOS_DEPLOYMENT_TARGET': '4.2',
          'OTHER_LDFLAGS': '(not found)',
          'PUBLIC_HEADERS_FOLDER_PATH': 'include/Cordova',
          'USER_HEADER_SEARCH_PATHS': '(not found)'}}}}

          --------------------------------------------------------------------------------
          Inspecting CordovaLib Version...

          VERSION file: 2.1.0
          CDVAvailability.h version: __CORDOVA_2_1_0

          -------------------------------------END--------------------------------------

          Shazron Abdullah added a comment -

          Sorry - run the updated diagnostic script (the last comment in the thread), and edit your comment above with that log.

          Shazron Abdullah added a comment -

          Replicated the problem on Xcode 4.5. Dupe of CB-1360, which will fix this problem. The fix is by removing the armv6 architecture from both your project and the CordovaLib project, clean both projects, and rebuild.

          Shazron Abdullah made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.2.0 [ 12322549 ]
          Resolution Duplicate [ 3 ]
          Shazron Abdullah made changes -
          Link This issue duplicates CB-1360 [ CB-1360 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          7h 43m 1 Shazron Abdullah 18/Sep/12 23:14

            People

            • Assignee:
              Shazron Abdullah
              Reporter:
              PJ Dillon
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development