Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-13623

Remove iOS 6-7 code from cordova-plugin-statusbar

VotersWatch issueWatchersLinkUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • None
    • None

    Description

      cordova-ios supports iOS 9 and newer, but cordova-plugin-statusbar still has a lot of IsAtLeastiOSVersion(@"7.0") code that is not needed.

      We should remove all the IsAtLeastiOSVersion(@"7.0") and remove any code in case there is an else for iOS 6 and iOS 7 specific code

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            jcesarmobile jcesarmobile
            jcesarmobile jcesarmobile
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment