Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-13140

Support for `bundleVersion` cli option

VotersWatch issueWatchersLinkUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Do
    • Affects Version/s: 4.4.0
    • Fix Version/s: None
    • Component/s: cordova-ios
    • Labels:
      None

      Description

      Issue:
      Add support for `bundleVersion` cli option in cordova-ios package similar to `--vesionCode=1` in cordova-android package

      Actual result:
      No way to pass `bundleVersion` as cli option for `cordova build ios`

      Expected result:
      when `--bundleVersion=1` is passed it should be used as `CFBundleVersion` in info.plist

      cordova build ios --bundleVersion=1
      

      Currently in cordova-android it's possible to do this:

      cordova build android -- --versionCode=1
      

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              shazron Shazron Abdullah
              Reporter:
              sergii.stotskyi Sergii Stotskyi

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment