Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-13022

cordova-windows' check_reqs asks for VS 2013/2015, but any higher version would do

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: cordova-windows
    • Labels:
      None

      Description

      When a user doesn't have VS installed and runs check_reqs, the following warning is displayed:

      Requirements check results for windows:
      Windows OS: installed Windows 10
      MSBuild Tools: not installed
      MSBuild tools v.14.0 not found. Please install Visual Studio 2015 Community from https://www.visualstudio.com/downloads/download-visual-studio-vs
      Visual Studio: not installed
      Required version of Visual Studio not found. Please install Visual Studio 2015 Community from https://www.visualstudio.com/downloads/download-visual-studio-vs
      Windows SDK: installed 10.0
      Windows Phone SDK: installed 10.0
      Error: Some of requirements check failed
      

      The phrase "Please install Visual Studio 2015 Community" is somewhat misguiding, because any higher version of VS also will do.

      I propose to insert "or higher" here.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                alsorokin Alexander Sorokin
                Reporter:
                alsorokin Alexander Sorokin
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: