Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-12807

Improve error message for bad templates when using cordova create --template

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.1
    • Fix Version/s: None
    • Component/s: cordova-create

      Description

      right now, we don't handle the error very well when you are using a invalid template during cordova create --template sometemplate. We just spew out the npm stack. It would be better if we could catch the error and provide a nicer message to our users. Something along the lines of the template is invalid. Make sure you follow the template guide when creating a template. (link to template guide). Templates now require a package.json.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                auso Audrey So
                Reporter:
                stevegill Steve Gill
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: