Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-11923

Glob library inside cordova is using minimatch@2.0.10

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 6.3.1
    • Fix Version/s: None
    • Component/s: cordova-js
    • Labels:
      None

      Description

      Full description here

      http://stackoverflow.com/questions/39727130/npm-warn-deprecated-minimatch2-0-10-but-i-a-newer-version

      cordova-cli:

      ├─┬ cordova-common@1.4.1
      │ └── minimatch@3.0.3
      └─┬ cordova-lib@6.4.0-nightly.2016.9.19.f8b58c78
        ├─┬ cordova-js@4.1.4
        │ └─┬ browserify@10.1.3
        │   └─┬ glob@4.5.3
        │     └── minimatch@2.0.10
        └─┬ npm@2.15.11
          └── minimatch@3.0.3
      

      Looks like cordova-js has to update browserify -> glob -> minimatch

        Attachments

          Activity

            People

            • Assignee:
              shazron Shazron Abdullah
              Reporter:
              elieobeid7 Elie Obeid
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: