Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-10530

App freezes sometimes directly after starting on iOS

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 6.0.0
    • Fix Version/s: None
    • Component/s: iOS
    • Environment:

      OSX El Capitan 10.11.3, XCODE (7.2.1), iOS 9.2.1, cordova 6.0.0, ionic 1.7.14

      Description

      • Installed the "ionic start myApp sidemenu" example application
      • Start XCODE (7.2.1)
      • Start the app by clicking the run button from xCODE
      • The app probably starts as expected.
      • Repeat the start process until the app freezes.

      The app sometimes freezes completely. If this happens you cannot do anything with the app (you need to push the home button and close the app via task manager). I had the same issue for another more complex app.

      The CPU stays at around 99% workload.
      I made a snapshot of the profiler (Instruments)

      1. Instruments.trace.zip
        366 kB
        Florian Krüger
      2. Screen Shot 2016-02-23 at 3.20.37 PM.png
        605 kB
        Adrian Florin Florescu
      3. Screen Shot 2016-02-23 at 3.21.55 PM.png
        819 kB
        Adrian Florin Florescu

        Issue Links

          Activity

          Florian Krüger Florian Krüger added a comment -

          CPU trace of freezing application

          zarko Zarko Hristovski added a comment -

          Likely related case over at Ionic's Github - "bug: Launch freeze/crash on manual splash screen hiding":
          https://github.com/driftyco/ionic/issues/5324

          mhartington Mike Hartington added a comment -

          Looking into this, it appears to be a race condition between the device plugin and the splash screen plugin. If you use only one of them, there's no issues. But if you use both, you occasionally break device ready and prevent it from firing. This is seen in both a vanilla cordova project as well as a ionic project.

          mhartington Mike Hartington added a comment -

          here's a project that has the issue. Running from xcode, you can see that after several runs, devcie.ready freezes and the whole webview become unresponsive. While it does load the html, you can't interact with it and you can't attach safari's dev tools either.

          project zip

          cc Shazron Abdullah

          michaelstanford Michael Stanford added a comment - - edited

          Easily reproduced with a new empty project. Add the device and console plugins, and the iOS platform. Then in the onDeviceReady function put a console log statement, followed by a delay loop of about 100ms. Run it on the 6S simulator. Console log never executes. CPU pegs. Reduce the delay to about 50ms and everything works great.

          ross Ross Holdway added a comment -

          Also interesting to note that I'm only getting this issue with Cordova iOS 4.0.0 and 4.0.1. Easily reproduce with https://github.com/rossholdway/ionic-ios-cordova-bug

          michaelstanford Michael Stanford added a comment - - edited

          Yes - the iOS platform version I am testing with is iOS 4.0.1. Other plugins triggering this issue include:

          • cordova-plugin-network-information
          • cordova-plugin-statusbar
          toostn Torsten Freyhall added a comment -

          I recreated the issue as described by Michael Stanford and tried some strategies to make it disappear.

          The issues seems to be related to the failSafeTimerId set in pokeNative function in cordova-js-src/exec.js.

          If the sum of the execution time for deviceready callback events is more than ~50 ms it calls the gap://ready again, which I guess replaces the current command stack with an empty one or something like that (I'm just guessing here)

          I've worked around this by increasing the timeout interval from 50ms to 1000ms, however this probably renders the timeout useless.

          To edit this in your project, go to Staging / www / cordova.js, row 990. (in Xcode), and edit the interval there.

          Project to reproduce and test fix:
          https://github.com/toostn/cordova-ios-timer-bug

          toostn Torsten Freyhall added a comment - - edited

          Checked a little more, and the reason for the freeze is because the handleBridgeChange() function always indicates that the bridge has changed since `if (execProxy !== cordovaExec())` always returns true.

          Bridge change causes the current command stack to be executed in the new bridge, which then runs pokeNative again. The handleBridgeChange basically does while(var a = stack.shift())

          { exec(a) }

          and then exec(a) does stack.push(a), which causes the inifinite loop since stack is never emptied, because the bridge hasn't actually changed.

          This was changed in the recent commit f2e056e5fe945801b518b752871f5c64c0a28a88, which makes sense since this was changed between cordova-ios 3.9 and 4.0.

          I can't really understand what is the intended check, maybe Shazron Abdullah can have a look at what was intented?

          toostn Torsten Freyhall added a comment -

          Also pinging Jesse MacFadyen who also seem to have commited code to this file recently regarding bridges.

          shazron Shazron Abdullah added a comment -

          I'm looking at this as a priority - probably won't be able to get to it until Monday 2/15 however.

          shazron Shazron Abdullah added a comment -

          Finished my investigation. The reasons for the proxy are listed in CB-10106. Like Torsten has found initially, there is faulty logic here: https://github.com/apache/cordova-ios/blob/4ca3f28bae30b0974da7a7a4033d158b08303c4c/cordova-js-src/exec.js#L139

          The return value for cordovaExec() can be iosExec and not a proxy object, and that has to be taken into account.

          githubbot ASF GitHub Bot added a comment -

          GitHub user shazron opened a pull request:

          https://github.com/apache/cordova-ios/pull/193

          CB-10530 - App freezes sometimes directly after starting on iOS

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/shazron/cordova-ios CB-10530

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/cordova-ios/pull/193.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #193


          commit 7d6bc772e06999f62cea39bbb87f1508860d5cb6
          Author: Shazron Abdullah <shazron@apache.org>
          Date: 2016-02-16T23:26:24Z

          CB-10530 - App freezes sometimes directly after starting on iOS


          shazron Shazron Abdullah added a comment -

          Pull request sent.
          Please test by adding the platform:

          cordova platform add https://github.com/shazron/cordova-ios.git#CB-10530
          
          shazron Shazron Abdullah added a comment -

          Sorry give me half an hour - i forgot to re-generate cordova.js

          shazron Shazron Abdullah added a comment -

          Done

          louisjr@julojostudio.com Louis Lor Jr. added a comment -

          Thanks for the update! It works perfectly for me, not able to reproduce the freeze again.

          ross Ross Holdway added a comment -

          Tested and working well. Can't reproduce the freeze. Thanks!

          toostn Torsten Freyhall added a comment -

          Yes, this does indeed solve the freeze in my test project.

          However I was not sure about why the timer resolves due to long script execution times though. It seems like the intention is that whenever gap://ready is loaded in the iframe, the immediate response from the native side should be to call nativeFetchMessages() which should clear the timeout.

          Therefore I dug a little deeper in the native side, and found that the evaluateJavaScript:completionHandler: in CDVCommandQueue expects implementation to to be async (a comment in the code says so), but the CDVUIWebViewEngine method actually is implemented synchronous.

          I wrapped the entire method in a dispatch_async call (maybe a very naive solution, it might mess with references?):

          dispatch_async(dispatch_get_main_queue(), ^{
          NSString* ret = [(UIWebView*)_engineWebView stringByEvaluatingJavaScriptFromString:javaScriptString];

          if (completionHandler)

          { completionHandler(ret, nil); }

          });

          This also solves the original issue on cordova-ios 4.0.1 as the timeout never resolves, so maybe asyncing this method should also be a part of the proper fix?

          githubbot ASF GitHub Bot added a comment -

          Github user dpogue commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-185951530

          :+1: from me. I have not seen the splashscreen hanging bug while testing this branch.

          githubbot ASF GitHub Bot added a comment -

          Github user mhartington commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-185951944

          Same here, couldn't get anything to break for me. Thanks!

          githubbot ASF GitHub Bot added a comment -

          Github user thomasMary commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-186005928

          Works for me. Thanks

          githubbot ASF GitHub Bot added a comment -

          Github user csantanapr commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-186017788

          Thanks @mhartington for testing you were able to recreate very easy in your setup.

          jopelkey Jo Pelkey added a comment -

          I can also verify that running against
          https://github.com/shazron/cordova-ios CB-10530
          fixes the issue for me. Thank you for the fix.

          I see that this is tagged for cordova-ios-4.1.0

          Is there any visibility into when 4.1.0 will be officially released? Given the critical nature of this bug, hopefully it will be very soon?!

          githubbot ASF GitHub Bot added a comment -

          Github user mindhells commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-187152531

          Thank you!
          this works for me... but still have problems with splashscreen plugin (had to remove it in order to make sure the app initializes well every time).
          This is my plugin list now:
          cordova-plugin-app-event 1.2.0 "Application Events"
          cordova-plugin-customurlscheme 4.1.3 "Custom URL scheme"
          cordova-plugin-datepicker 0.9.3 "DatePicker"
          cordova-plugin-device 1.1.1 "Device"
          cordova-plugin-inappbrowser 1.2.1 "InAppBrowser"
          cordova-plugin-network-information 1.2.0 "Network Information"
          cordova-plugin-whitelist 1.2.1 "Whitelist"
          cordova-plugin-x-socialsharing 5.0.10 "SocialSharing"
          cordova-plugin-x-toast 2.4.2 "Toast"
          de.appplant.cordova.plugin.local-notification 0.8.4 "LocalNotification"
          ionic-plugin-keyboard 1.0.8 "Keyboard"
          phonegap-plugin-push 1.5.3 "PushPlugin"

          githubbot ASF GitHub Bot added a comment -

          Github user michschu commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-187600116

          Not having a problem with
          cordova-plugin-splashscreen 3.1.0 "Splashscreen"
          However
          _cordova-plugin-inappbrowser 1.2.1 "InAppBrowser"
          cc.fovea.cordova.purchase 4.0.0 "Purchase"_
          seem not to work anymore.

          Currently no time to provide a test scenario. Anybody having a chance to confirm (or not)?

          adrianflorinflorescu Adrian Florin Florescu added a comment - - edited

          This happens to me too, but only on iOS 8.3 and I have installed ios 4.0.1

          I've attached a screenshot.

          The memory keeps rising until I get: "The app "Vivre" on "Adrian Florescu’s iPhone" quit unexpectedly. Message from debugger: Terminated due to Memory Error".

          Sometimes the app launches just fine. Not sure how to debug.

          adrianflorinflorescu Adrian Florin Florescu added a comment -

          This works for me

          adrianflorinflorescu Adrian Florin Florescu added a comment -

          Shazron Abdullah's solution works for me. Tested on real devices iPhone 5c with iOS 8.3 and iPhone 6 with iOS 9.2.1

          adrianflorinflorescu Adrian Florin Florescu added a comment -

          These are the only changes made, right? https://github.com/apache/cordova-ios/compare/master...shazron:CB-10530

          Do you think it's safe for submitting in the app store?

          githubbot ASF GitHub Bot added a comment -

          Github user rpayanm commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-187893848

          :+1: Works for me.

          githubbot ASF GitHub Bot added a comment -

          Github user adyz commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-188126958

          Works for me too

          jira-bot ASF subversion and git services added a comment -

          Commit afe10278d3ee5899b73a140b55f78361ed8606f3 in cordova-ios's branch refs/heads/master from Shazron Abdullah
          [ https://git-wip-us.apache.org/repos/asf?p=cordova-ios.git;h=afe1027 ]

          CB-10530 - App freezes sometimes directly after starting on iOS

          jira-bot ASF subversion and git services added a comment -

          Commit a36259abf6a671a3f5b0c47d237c29a515aaa5a8 in cordova-ios's branch refs/heads/master from Shazron Abdullah
          [ https://git-wip-us.apache.org/repos/asf?p=cordova-ios.git;h=a36259a ]

          CB-10530 - Updated cordova.js. This closes #193

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/cordova-ios/pull/193

          toostn Torsten Freyhall added a comment -

          Shazron Abdullah Did you read my comment above about the root cause of the timer firing being CDVUIWebViewPlugin being synchronous? I think that might need to be addressed as well to prevent future issues, even if the javascript patch solves the reported issue.

          githubbot ASF GitHub Bot added a comment -

          Github user mix3d commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-191322061

          How can we start using this without waiting for an official platform update? Been running into this at work, and the powers that be want it fixed asap.

          githubbot ASF GitHub Bot added a comment -

          Github user mix3d commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-191325580

          beautiful. Thanks @rpayanm!

          githubbot ASF GitHub Bot added a comment -

          Github user stevengill commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-191349466

          cordova-ios 4.1.0 should be coming out later today. Keep an eye out for the blog post to hit the cordova site.

          michaelstanford Michael Stanford added a comment -

          Steven - did you check the validity of Torsten Freyhall's point above?
          >>"Did you read my comment above about the root cause of the timer firing being CDVUIWebViewPlugin being synchronous? I think that might need to be addressed as well to prevent future issues, even if the javascript patch solves the reported issue."

          githubbot ASF GitHub Bot added a comment -

          Github user mix3d commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-191390888

          Thanks @stevengill - I've been checking it daily for almost the last week. Eyes are well peeled.

          shazron Shazron Abdullah added a comment -

          Hi Torsten,
          We must have missed that - that can go in a 4.1.1 patch release. If you could be so kind to file a new issue regarding this and assign it to me? Thanks.

          githubbot ASF GitHub Bot added a comment -

          Github user shazron commented on the pull request:

          https://github.com/apache/cordova-ios/pull/193#issuecomment-191553897

          cordova-ios-4.1.0 has been released, thanks to Steve! http://cordova.apache.org/announcements/2016/03/02/ios-4.1.0.html

          toostn Torsten Freyhall added a comment -

          I created this story:
          https://issues.apache.org/jira/browse/CB-10774

          I don't think I can assign it to you, but maybe you can claim it somehow?

          Florian Krüger Florian Krüger added a comment -

          Thank you very much We cannot reproduce the error now.

          Florian Krüger Florian Krüger added a comment -

          I can't reproduce the bug with 4.1.0.

          jira-bot ASF subversion and git services added a comment -

          Commit 0770392d97f5e81f7bcc2ef1ce917c042f5f888b in cordova-plugins's branch refs/heads/master from Shazron Abdullah
          [ https://git-wip-us.apache.org/repos/asf?p=cordova-plugins.git;h=0770392 ]

          Incremented plugin version to 2.4.0 to account for the GCDWebServer upgrade to 3.3.3~3.3.4 from 3.1.0.
          Incremented cordova-ios requirement to minimum 4.1.0 for CB-10530.

          This closes #23


            People

            • Assignee:
              stevegill Steve Gill
              Reporter:
              Florian Krüger Florian Krüger
            • Votes:
              11 Vote for this issue
              Watchers:
              23 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development