Uploaded image for project: 'Cayenne'
  1. Cayenne
  2. CAY-2333 Project XML extensions
  3. CAY-2339

Compatibility module to support old versions of projects at runtime

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.M1
    • Fix Version/s: 4.1.M1
    • Component/s: Core Library
    • Labels:
      None

      Description

      New XML loading fails to load old versions buy default. Though this incompatible behavior but it is much safer to use by default as it has no side effects that were possible.

      However we can create separate module that can perform project upgrade on the fly, so it will be possible to still use old projects that impossible to upgrade (e.g. it can be part of some third-party library).

        Attachments

          Activity

            People

            • Assignee:
              ntimofeev Nikita Timofeev
              Reporter:
              ntimofeev Nikita Timofeev
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: