As postcommit module's name is not clarifies its purpose and clashes with POST_COMMIT callback it is proposed to change its name to commitlog.
This requires some braking changes, namely:
- introduce new annotation @CommitLog instead of @Auditable
- move all postcommit module's code into new packages (org.apache.cayenne.commitlog.*)
- rename Postcommit* classes